Ako si nastaviť verziu PHP na svojom hostingu?


Jednou z predností webhostingu (resp. mutlihostingu) u ACTIVE 24 je možnosť flexibilného prepínania verzií PHP. Zákazník môže teda zvoliť takú verziu PHP, ktorú aktuálne potrebuje alebo má možnosť testovať, ako sa web chová na rôznych verziách PHP úplne bez vplyvu na ostatných návštevníkov webu.

Doteraz mali všetky naše hostingové servery v ponuke tri verzie PHP a síce 5.3, 5.2 a 4.4. Servery ale pravidelne aktualizujeme a na tom poslednom, kde sa aktuálne zriaďujú nové virtuály, sme verzie obmenili tak, že bolo doplnené celkom nové PHP 5.4 a naopak sme odstránili PHP 4.4.

Ak si dnes objednáte (alebo vrámci už existujúceho multihostingu zriadite) nový virtuálny server, bude na ňom nastavená implicitná verzia PHP 5.3. Tú je ale možné prostredníctvom nášho Zákazníckeho centra ľahko prepnúť napr. práve na PHP 5.4 a to v sekcii Virtuálne servery – ikonka okuliarov:


Druhá možnosť je tá, že verziu PHP nebudete priamo prepínať, ale len sa jednorázovo pozriete ako sa váš web v inej verzii chová, pričom na ostatných návštevníkov vašich stránok to nebude mať žiadny vplyv. Hodí sa to hlavne vo chvíli, keď sa chystáte na zmenu verzie a chcete si vopred bez rizika overiť, či je váš web na zmenu pripravený a prípadne ho najskôr doladiť. Urobíte to tak, že do URL doplníte za dvojbodkou číslo portu, na ktorom beží webserver s príslušnou verziou PHP. Teda ak napr. na stránkach www.vasefirma.cz beží PHP 5.3 a vy sa chcete pozrieť na to ako by to vyzeralo na verzii 5.4, stačí do prehliadača zadať URL http://www.vasefirma.cz:84/

Momentálne využívame porty 84, 85 a 86, pričom aká verzia beží na ktorom porte príslušného servera zistíte ľahko tak, že si zobrazíte zodpovedajúce phpinfo napr. takto:http://uvirt25.active24.cz:84/info.php

Starú verziu 4.4, ktorá už nie je podporovaná a beží na starších serveroch, plánujeme postupne ukončiť (zatiaľ bez upresnenia termínu) a weby, ktoré ho používajú, previesť na PHP 5.2. Ak váš web beží ešte na starom PHP 4.4, využite túto príležitosť na otestovanie, či na verzii 5.2 prípadne 5.3 pobeží rovnako dobre a v Zákazníckom centre si ju následne prepnete.

Na našich virtuálnych managed serveroch (VMS) funguje všetko vyššie spomínané analogicky a ak server neponúka verziu PHP, ktorú ponúkame inde, stačí nám napísať, aby sme ju doplnili. Tí náročnejší z vás, ktorí si objednajú server VMS Premium Plus, môžu dokonca vyžadovať celkom individuálnu kompiláciu PHP v ľubovoľnej verzii s ľubovoľnými modulmi.

Zdeněk Brůna, technický riaditeľ ACTIVE 24

NAPIŠTE KOMENTÁŘ